TP-calcul-parallele/flake.nix

50 lines
1 KiB
Nix

{
inputs = {
nixpkgs = {
url = "github:NixOS/nixpkgs/nixos-unstable";
};
flake-parts = {
url = "github:hercules-ci/flake-parts";
inputs.nixpkgs-lib.follows = "nixpkgs";
};
systems = {
url = "github:nix-systems/default";
};
};
outputs = inputs @ {
nixpkgs,
flake-parts,
...
}:
flake-parts.lib.mkFlake {inherit inputs;} {
systems = import inputs.systems;
perSystem = {
pkgs,
system,
...
}: {
devShells.default = pkgs.mkShell {packages = with pkgs; [pandoc];};
packages.report = pkgs.stdenvNoCC.mkDerivation {
name = "report";
src = ./docs;
dontUnpack = true;
buildInputs = with pkgs; [pandoc];
buildPhase = ''
pandoc $src/report.md -s -o index.html --katex
'';
installPhase = ''
mkdir -p $out
cp -r $src/figs $out/figs
cp index.html $out/index.html
'';
};
};
};
}