projet-audionumerique/flake.nix

51 lines
1 KiB
Nix

{
inputs = {
nixpkgs = {
url = "github:NixOS/nixpkgs/nixos-unstable";
};
flake-parts = {
url = "github:hercules-ci/flake-parts";
inputs.nixpkgs-lib.follows = "nixpkgs";
};
systems = {
url = "github:nix-systems/default";
};
};
outputs = inputs @ {
nixpkgs,
flake-parts,
...
}:
flake-parts.lib.mkFlake {inherit inputs;} {
systems = import inputs.systems;
perSystem = {
pkgs,
system,
...
}: {
devShells.default =
pkgs.mkShell {packages = with pkgs; [marp-cli];};
packages.slides = pkgs.stdenvNoCC.mkDerivation {
name = "slides";
src = ./.;
dontUnpack = true;
buildInputs = with pkgs; [marp-cli];
buildPhase = ''
marp --html $src/slides.md --allow-local-files -o slides.html
'';
installPhase = ''
mkdir -p $out
cp -r $src/figs $out/figs
cp slides.html $out/index.html
'';
};
};
};
}