AI-or-not/flake.nix
2023-01-28 16:20:40 +01:00

25 lines
593 B
Nix

{
description = "Proj BE PI3D";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem (system:
let pkgs = nixpkgs.legacyPackages.${system};
in {
devShell = pkgs.mkShell {
buildInputs = with pkgs; [
tk
poetry
python3
python310Packages.numpy
python310Packages.datasets
python310Packages.matplotlib
];
};
});
}